Tæl antal unikke forekomster i Excel

Forums

I området A1 til A5:

=SUMPRODUKT(((A1:A5<>"")/TÆL.HVIS(A1:A5;A1:A5&"")))

Antal unikke forekomster kan også tælles i et navngivet område, hvilket gør det lidt nemmere at anvende funktionen.

Marker området og kald det for "unikke" og anvend derefter følgende formel i en tom celle.

=SUMPRODUKT(((unikke<>"")/TÆL.HVIS(unikke;unikke&"")))

Tæl.hvis specifik tekst i celleområde

Forums

Du kan tælle antallet af celleforekomster i et Excel regneark med en bestemt TEKST i et celleområde med tæl.hvis-funktionen.

Eksempel: tæl.hvis(a1:a10;"TEKST")

Bemærk at du også kan bruge wildcard med stjerne "*"

Du får derfor samme resultat med: tæl.hvis(a1:a10;"*EKS*")

Engelsk version af funktionen: countif.

Afprøvet i Excel 2007.

Excel - Minimum værdi større end nul "0"

Forums

Sådan finder du den mindste værdi, som er større end nul.

Celleområdet i eksemplet er A1:A5. Nul "0" kan erstattes med en anden værdi.

=MIN(HVIS((A1:A5>0);A1:A5))

Formlen afsluttes med "CTRL" + "SHIFT" + "Enter" for at angive at formlen er celleområdebaseret/listebaseret. 

Testet i Excel 2007.

Kopier noget af indholdet i en regnearkscelle

Forums

I din celle "A1" har du en adresse og et postnummer: "Danmarksvej 1, postnummer: 1000"

Du ønsker alt tekst til venstre for teksten "postnummer" i din resultatcelle "B1".

Først skal du finde ud af, hvor mange tegn der er til "postnummer". Det kan du gøre via SØG funktionen. Søg funktionen skal have information om, hvad du søger efter, hvilken celle du vil søge i og antal tegn talt fra venstre søgningen skal starte ved.

3 hurtige Exceltips

Forums

Funktionstasten "F11"

Du har en tabel med data og cellemarkøren er i tabellen. Et tryk på "F11" giver dig meget enkelt en graf, og du kan derefter vælge om det skal være et søjlediagram, cirkeldiagram eller et af de mange andre diagramtyper, som findes i Excel. Det er meget imponerende at se på, hvis denne funktion udnyttes optimalt.

Arkiv med regneark - Inventory Simulation

Forums

En søgning efter lagersimulering bragte mig frem til en hjemmeside lavet af Matt H. Evans - Creating Value through Excellence in Financial Management (exinfm). På hjemmesiden kan man finde et stort arkiv af links til interessante Excel-ressourcer og Excel-regneark, som kan benyttes frit!

Moneynet.dk - regneark på internettet og VBA-samling

Forums

lægge dit Excel-regneark på nettet for at afprøve funktionaliteten. Hvis du vil have webregneark på din egen hjemmeside, kan du også få hjælp til det via MoneyNet.dk.

Du tænker sikkert, at du lige så godt kan bruge Google Docs, men med webregneark har du fuld kontrol over dine data.

Hvis du har forslag til emner, som MoneyNet.dk skal tage fat på, er du velkommen til at skrive til GrN.dk.

Lopslag i Excel i praksis

Forums

Lodret opslag, kendt som lopslag i Excel er en nyttig funktion til opslag af værdier i en liste. 

Anvendelse

LOPSLAG(Opslagsværdi (i første kolonne) ; Opslagsområde ; Opslagskolonne for værdien som bliver returneret)

Det vedhæftede skærmbilledet viser, hvordan lopslag anvendes til udvælgelse af busture via celler mærket med en rød cirkel. Der foretages opslag i listen til venstre hvor de opslåede værdier er mærket med et blåt rektangel. Formlen for lopslag er i de blå markeringer i højre side. Via denne metode er det nemt at udskifte en bustur.