30 minutters ekspert-gennemgang af Excel-regneark

Forums

Specialpris på LogistikForum.org -  250 DKK inklusive alt. Jeg tilbyder en 30 minutters ekspertgennemgang af dit Microsoft Excel-regneark (gælder også OpenOffice/LibreOffice).

Du har et regneark, som du ikke kan komme videre med og skal have nogle tips og tricks til udvikling eller skal have valideret arket for fejl.

Brevflet data fra Excel til et dokument i Word

Forums

Brevfletning går typisk ud på at hente kontaktoplysninger på en række modtagere og flette dem ind i et brev. Det hedder "mail merge" på engelsk og her er en fin video, som viser hvordan det gøres.

Du kan også læse hvordan det gøres via VBA: http://www.kronsell.net/BrevfletningExcelWord.htm

Excel talsimulering og visning af celler der er større end nul

Forums

Et lille regnearks-eksempel, hvor vi først simulerer en talrække via slumpfunktionen og derefter kopierer værdierne til kolonne C i ark 1. En simpel "Hvis"-funktion i ark 2, viser kun værdier, som er over 0. Et filter sørger for, at alle tomme felter bliver skjult, så værdierne står under hinanden. Har du kun behov for unikke forekomster, kan du også bruge en pivottabel, som vist i arket med navnet "Pivot".

Hvilke værdier findes ikke i den anden kolonne

Forums

Et simpel metode til at sammenligne to kolonner med værdier. I det her tilfælde er vi interesserede i at finde værdier fra kolonne B, som ikke findes i kolonne C.

Den anvendte formel:

=IKKE(ER.IKKE.TILGÆNGELIG(LOPSLAG(B2;$C:$C;1;FALSK)))

Se vedhæftede regneark.

Løsning i R-project.

Tæl antal unikke forekomster i Excel

Forums

I området A1 til A5:

=SUMPRODUKT(((A1:A5<>"")/TÆL.HVIS(A1:A5;A1:A5&"")))

Antal unikke forekomster kan også tælles i et navngivet område, hvilket gør det lidt nemmere at anvende funktionen.

Marker området og kald det for "unikke" og anvend derefter følgende formel i en tom celle.

=SUMPRODUKT(((unikke<>"")/TÆL.HVIS(unikke;unikke&"")))